ftpgroups - FTP Server enhanced group access file
The ftpgroups file contains the enhanced group access information.
After login, if the ftpaccess(4) file includes private yes, the user may use the SITE GROUP and SITE GPASS commands to specify an enhanced access group and a password for that group. If the access group name and password are valid, the FTP Server executes setegid(2) to make the user a member of the real group listed in the ftpgroups file.
The format for the ftpgroups file is:
The fields are defined as follows:
accessgroupAn arbitrary string of alphanumeric and punctuation characters.
encrypted_passwordThe group password encrypted exactly like in /etc/shadow.
real_group_nameThe name of a valid group returned by getgrnam(3C).
The privatepw utility is an administrative tool to add, delete and list enhanced access group information in the ftpgroups file. See privatepw(1M). Lines that begin with a # sign are treated as comment lines and are ignored.
See attributes(5) for descriptions of the following attributes:
ATTRIBUTE TYPE ATTRIBUTE VALUE Availability SUNWftpr
in.ftpd(1M), privatepw(1M), setegid(2), getgrnam(3C), ftpaccess(4), group(4), shadow(4), attributes(5)
|SunOS 5.11||ftpgroups (4)||1 May 2003|