gnome-vfs.applications - GNOME VFS application registry
The GNOME MIME magic and MIME info files (see gnome-vfs-mime-magic(4)) enable GNOME VFS to associate a data file with its icon and description. The GNOME VFS application registry provides a way to launch the applications associated with such files.
The registration of applications to various MIME types is specified in text files placed in the /usr/share/gnome/application-registry directory. GNOME provides a default registry file called gnome-vfs.applications. Vendor-specific registry files can also be placed in this directory. This information is used extensively by nautilus(1), the GNOME file manager.
The format of the application registry file is simple. Each application entry is made up of a name followed by a number of key-value pairs. The application name must have been specified in one of the .keys files. The minimum required key fields are as follows:
command The command to execute.
name The descriptive name of the command, which will appear in the Open With menu in Nautilus.
can_open_multiple_files The value of this field can be true or false.
expects_uris The value of this field can be true or false. This field tells Nautilus whether the application can accept http:, ftp: and so on specifications to open at the command line. If this is true, you must add the supported_uri_schemes field.
requires_terminal The value of this field can be true or false.
mime_types The list of comma-separated mime-types defined by MIME magic or MIME info files.
supported_uri_schemes Specifies the list of protocols supported by the application; for example, http, ftp, file, telnet, gopher.
Example 1: Registering CDE Imagetool with GNOME Application Registry
sdtimage command=sdtimage name=sdtimage can_open_multiple_files=false expects_uris=false requires_terminal=false mime_types=image/tiff,image/gif,application/postscript,image/jpeg,x-xpixmap
Example 2: Registering Netscape with GNOME Application Registry
netscape command=netscape name=Netscape can_open_multiple_files=true expects_uris=true requires_terminal=false supported_uri_schemes=file,http,ftp,telnet,gopher mime_types=text/html,x-directory/webdav,x-directory/webdav-prefer-directory,image/gif,image/jpeg
See environ(5) for descriptions of the following environment variables that affect the execution of gnome-vfs.applications: NLSPATH.
The following files are used by this application:
See attributes(5) for descriptions of the following attributes:
ATTRIBUTE TYPE ATTRIBUTE VALUE Availability SUNWgnome-vfs Interface stability Volatile
nautilus(1), gnome-vfs-mime-magic(4), libgnomevfs-2(3)
Latest version of the GNOME Desktop User Guide for your platform.
Written by Ghee Teo, Sun Microsystems Inc., 2003.
|SunOS 5.11||gnome-vfs.applications.4 (4)||13 Jan 2003|